Jump to content
danielegenova

Errore accesso al forum

Recommended Posts

danielegenova

Mi hanno hackerato il forum...

Ho cancellato tutto via ftp e ho reimportato un backup.

Prima appariva pagina bianca ora appare:

 

Spiacenti, non abbiamo potuto individuare la pagina richiesta. Fai clic qui per tornare all'indice del forum

 

Link Utili

 

Se provo ad accedere mi fa ritornare a questa pagina.

 

Idee?

 

Grazie

Share this post


Link to post
Share on other sites
Askancy

Ciao sei sicuro di aver caricato il backup correttamente, o che il backup non fosse corrotto? Perché sembra che se provi ad accedere alla pagina admin (http://www.macvillage.it/admin/) hai degli errori:


Warning: require_once(/web/htdocs/www.macvillage.it/home/admin/applications/core/modules_admin/login/manualResolver.php) [function.require-once]: failed to open stream: No such file or directory in /web/htdocs/www.macvillage.it/home/admin/sources/base/core.php on line 1180

Fatal error: require_once() [function.require]: Failed opening required '/web/htdocs/www.macvillage.it/home/admin/applications/core/modules_admin/login/manualResolver.php' (include_path='.:/php5/lib/php/:/web/htdocs/www.macvillage.it/home/ips_kernel/') in /web/htdocs/www.macvillage.it/home/admin/sources/base/core.php on line 1180

Prova a ricaricare i seguenti file, per vedere se riesci ad entrare in admin e ripristinare i permessi.

 

1 ora fa, Daniele Dallorto dice:

Ho cancellato tutto via ftp e ho reimportato un backup.

Che danno ti aveva causato "l'attacco" hacker? perché sei arrivato al punto di dover cancellare tutto? :huh:

Share this post


Link to post
Share on other sites
danielegenova
6 ore fa, Askancy dice:

Ciao sei sicuro di aver caricato il backup correttamente, o che il backup non fosse corrotto? Perché sembra che se provi ad accedere alla pagina admin (http://www.macvillage.it/admin/) hai degli errori:



Warning: require_once(/web/htdocs/www.macvillage.it/home/admin/applications/core/modules_admin/login/manualResolver.php) [function.require-once]: failed to open stream: No such file or directory in /web/htdocs/www.macvillage.it/home/admin/sources/base/core.php on line 1180

Fatal error: require_once() [function.require]: Failed opening required '/web/htdocs/www.macvillage.it/home/admin/applications/core/modules_admin/login/manualResolver.php' (include_path='.:/php5/lib/php/:/web/htdocs/www.macvillage.it/home/ips_kernel/') in /web/htdocs/www.macvillage.it/home/admin/sources/base/core.php on line 1180

Prova a ricaricare i seguenti file, per vedere se riesci ad entrare in admin e ripristinare i permessi.

Proverò, grazie

6 ore fa, Askancy dice:

 

Che danno ti aveva causato "l'attacco" hacker? perché sei arrivato al punto di dover cancellare tutto? :huh:

I tecnici di Aruba mi hanno detto che si era "insinuato" del codice malevolo e che dovevo cancellare e ricaricare. 

Così ho fatto....

Share this post


Link to post
Share on other sites
danielegenova

Provato a caricare quei files.... Non erano stati caricati ^_^

Ora va! Grazie mille!!

Ultima cosa: le discussioni non hanno più il permanent link di prima. Come faccio a ripristinarlo?

Grazie :)

Share this post


Link to post
Share on other sites
Askancy
33 minuti fa, Daniele Dallorto dice:

Provato a caricare quei files.... Non erano stati caricati ^_^

Ora va! Grazie mille!!

Ultima cosa: le discussioni non hanno più il permanent link di prima. Come faccio a ripristinarlo?

Grazie :)

AdminCP > System > System Settings > System > Search Engine Optimization, e attiva come nell'immagine:

ccs-85489-0-40775800-1366005229.png

Se così fosse, controlla di avere l'htaccess hostato nella cartella principale dove si trovano i file di IPB.

55 minuti fa, Daniele Dallorto dice:

I tecnici di Aruba mi hanno detto che si era "insinuato" del codice malevolo e che dovevo cancellare e ricaricare. 

Diciamo che sarebbe bastato controllare i file modificati di recente... :lol:

Share this post


Link to post
Share on other sites
danielegenova
9 ore fa, Askancy dice:

AdminCP > System > System Settings > System > Search Engine Optimization, e attiva come nell'immagine:

ccs-85489-0-40775800-1366005229.png

Se così fosse, controlla di avere l'htaccess hostato nella cartella principale dove si trovano i file di IPB.

Ho l'htaccess nella root dove c'è il forum e le impostazioni sono quelle (prima il "redirect to new friendly url format" era su "no")

Il permanent link non si attiva.

9 ore fa, Askancy dice:

Diciamo che sarebbe bastato controllare i file modificati di recente... :lol:

L'ho fatto ma le modifiche ai files erano di diversi mesi fa (il forum andava)

Share this post


Link to post
Share on other sites
danielegenova

Ho guardato l'htaccess e ha le impostazioni di Wordpress (che è in una sottocartella)...

Cita

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Ho messo quelle corrette:

Cita

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(jpeg|jpg|gif|png)$ /public/404.php [NC,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

Ma continua a non andare :(

Share this post


Link to post
Share on other sites
danielegenova

Ho controllato anche che nel file conf_global.php ci fosse (è presente)

$INFO['use_friendly_urls'] = '1';

Share this post


Link to post
Share on other sites
Askancy
5 ore fa, Daniele Dallorto dice:

Ho controllato anche che nel file conf_global.php ci fosse (è presente)


$INFO['use_friendly_urls'] = '1';

Sinceramente è molto strana questa cosa, prova a disabilitare il friendly url dal menu che ti ho detto prima, salva le modifiche, e riattivalo, non vorrei che avendo fatto l'upload dei file sia stata sovrascitta qualche modifica di attivazione..

Share this post


Link to post
Share on other sites
danielegenova
3 ore fa, Askancy dice:

Sinceramente è molto strana questa cosa, prova a disabilitare il friendly url dal menu che ti ho detto prima, salva le modifiche, e riattivalo, non vorrei che avendo fatto l'upload dei file sia stata sovrascitta qualche modifica di attivazione..

Provato ma nulla :(

Share this post


Link to post
Share on other sites
danielegenova
8 ore fa, Askancy ha scritto:

Ma perché non prendi in considerazione l'idea di effettuare l'upgrade a IPS4?

Mi sa che lo farò 

Share this post


Link to post
Share on other sites
danielegenova
Il 4/6/2016 at 20:23, BomAle ha scritto:

vieni reindirizzato ad un altro sito?

No

Il 4/6/2016 at 20:23, BomAle ha scritto:

vedo che i link ai topic vengono trasformati correttamente ora, confermi?

Stranamente si :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Crea Nuovo...

Important Information

By using this site, you agree to our Terms of Use.