Jump to content
Matte 6464

quote

Recommended Posts

Matte 6464

buongiorno a tutti....

 

ho appen aggiornato il forum da 3.4.7 a 4 ma tutti i messaggi che contengono messaggi quotati sono diventati dei testi unici anche se controllando a livello script contengono ancora la stringa di quotatura....

 

come posso risolvere??

 

Share this post


Link to post
Share on other sites
Askancy

buongiorno a tutti....

 

ho appen aggiornato il forum da 3.4.7 a 4 ma tutti i messaggi che contengono messaggi quotati sono diventati dei testi unici anche se controllando a livello script contengono ancora la stringa di quotatura....

 

come posso risolvere??

 

Il problema si limita ai quote o anche ai link/immagini avatar? Hai una licenza valida per IPB? perché ipb3.* faceva uso di BBCode invece IPB4 usa direttamente l'html nel CKEditor... E durante l'upgrade il sistema converte automaticamente i tag.

Questo problema il 95% delle volte è causato da una ipb di dubbia provenienza, inoltre ti consiglio di non avventurarti in queste cose se è la tua prima volta.

 

Comunque sia, nella buona fede che hai una IPB con licenza, controlla che i post non facciano uso di bbcode ma di html, se utilizzano il bbcode effettua un backup del db e procedi: https://community.invisionpower.com/topic/408366-broken-quotes-images-links-avatar-heres-my-fixes/

 

Ti consiglio di effettuare una copia di backup dell'sql

Share this post


Link to post
Share on other sites
Matte 6464

Il problema si limita ai quote o anche ai link/immagini avatar? Hai una licenza valida per IPB? perché ipb3.* faceva uso di BBCode invece IPB4 usa direttamente l'html nel CKEditor... E durante l'upgrade il sistema converte automaticamente i tag.

Questo problema il 95% delle volte è causato da una ipb di dubbia provenienza, inoltre ti consiglio di non avventurarti in queste cose se è la tua prima volta.

 

Comunque sia, nella buona fede che hai una IPB con licenza, controlla che i post non facciano uso di bbcode ma di html, se utilizzano il bbcode effettua un backup del db e procedi: https://community.invisionpower.com/topic/408366-broken-quotes-images-links-avatar-heres-my-fixes/

 

Ti consiglio di effettuare una copia di backup dell'sql

sto facendo tutto su una versione di test con copia del sito e del db per evitare perdite di dati

il problema è che me li ha convertiti da bbcode ad html ma comunque non me li mostra come quotati ma in testo senza cornici o altro...

se faccio l'edita del messaggio me lo mostra con la linea laterale ma nel post invece è come se non ci fosse nulla....

Share this post


Link to post
Share on other sites
Askancy

sto facendo tutto su una versione di test con copia del sito e del db per evitare perdite di dati

il problema è che me li ha convertiti da bbcode ad html ma comunque non me li mostra come quotati ma in testo senza cornici o altro...

se faccio l'edita del messaggio me lo mostra con la linea laterale ma nel post invece è come se non ci fosse nulla....

Potresti mettere uno screen del messaggio, e uno screen della query del messaggio con l'html? così possiamo capire meglio...

Share this post


Link to post
Share on other sites
Matte 6464

qui allego

visualizzazione messaggio

editing messaggio

html del messaggio

post-2726-0-14652400-1444229117_thumb.pn

post-2726-0-05074200-1444229119_thumb.pn

post-2726-0-82049200-1444229119_thumb.pn

Edited by Matte 6464

Share this post


Link to post
Share on other sites
Askancy

qui allego

visualizzazione messaggio

editing messaggio

html del messaggio

Per curiosità... provi a cambiare la classe del blackquote da ipsBlockquote a ipsQuote? Inoltre quello è un modifica?

Se tu metti una nuova citazione premendo il tasto del CKEditor quale delle due classi ti inserisce di default?

Share this post


Link to post
Share on other sites
Matte 6464

Per curiosità... provi a cambiare la classe del blackquote da ipsBlockquote a ipsQuote? Inoltre quello è un modifica?

Se tu metti una nuova citazione premendo il tasto del CKEditor quale delle due classi ti inserisce di default?

con ipsQuote funziona anche se non con tutti i dati di che è stato quotato

 

di defoult mette ipsQuote come class ma usa molti più dati rispetto a prima....

Grazie ancora

Share this post


Link to post
Share on other sites
Askancy

con ipsQuote funziona anche se non con tutti i dati di che è stato quotato

 

di defoult mette ipsQuote come class ma usa molti più dati rispetto a prima....

Grazie ancora

 

Ok quindi non hai usato l'ultima versione disponibile, perché questo è un bug del vecchio sistema di upgrade...

 

Vai su System->Support->Something isn't working correctly.

 

Prova a risolverlo così, nel caso ti consiglio di utilizzare la board aggiornata e magari con la licenza...

 

https://community.invisionpower.com/4bugtrack/archived-reports/css-for-v34x-ipboard-quotes-missing-in-upgrade-r1221/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Crea Nuovo...

Important Information

By using this site, you agree to our Terms of Use.