Jump to content
Michele Bortolato

Embed youtube opzionali

Recommended Posts

Michele Bortolato

Salve,

chiedevo se esiste un tool per permettere, a chi lo abilita, di non avere l'anteprima dell'embed youtube. Alcuni si lamentano della pesantezza di alcune pagine piene di embed ed un tool del genere farebbe al caso mio.

Grazie

Share this post


Link to post
Share on other sites
BomAle

puoi creare una skin doppia e in una delle due modifichi il css specificando che i file "media" non devono essere visibili ... se hai intenzione di seguire questa procedura ti posso pure fornire il css da usare!

Share this post


Link to post
Share on other sites
BomAle

si potrebbe fare aggiungendo questo codice nel css


/* Disattivazione Video */
embed, video {visibility:hidden;}

oppure gli metti display:none cosi almeno non fai vedere uno spazio vuoto in mezzo!

Share this post


Link to post
Share on other sites
Michele Bortolato

Ma con questa proprietà css ci si limita a non vedere l'embed oppure il browser evita di scaricare le l'intero elemento, perché quello che si vuole è evitare a chi lo richiede di appesantire il caricamento della pagina.

Grazie.

Share this post


Link to post
Share on other sites
Michele Bortolato

Allora io vorrei inserire tale proprietà nell'elemento embed sottoforma di attributo "hidden=true", perché in qualsiasi css in cui metto tale proprietà non mi apporta le modifiche.

Soltanto che non riesco a trovare il template in cui si configura l'elemento embed; ovviamente sto ancora prendendo familiarità con la gestione dei template, voi come avete fatto (o fareste)?

Grazie

Share this post


Link to post
Share on other sites
BomAle

quella parte di css andava messo nel ipb_styles.css .. prova con

/* Disattivazione Video */
embed, video {display:none !important;}

non capisco perchè allora tu vuoi inserire quell'attributo hidden all'embed ... non inserire il video ma linki solo il video (nel caso di youtube).

Edited by Skillman_92

Share this post


Link to post
Share on other sites
Michele Bortolato

Perché nei css su cui ho lavorato non mi beccava la property, proverò a fare un altro po' di test, grazie.

Share this post


Link to post
Share on other sites
Michele Bortolato

Voglio dire: sto lavorando in locale affiancandomi a firebug, e vedo che nonostante in ipb_styles.css abbia settato correttamente la property non mi viene letta la proprietà, nel senso che la console css di firebug non becca nessuna property per l'elemento embed... :wacko:

Share this post


Link to post
Share on other sites
BomAle

ti faccio sapere se ci sono alternative per disabilitare i video esempio dal pannello utente come scelta!

Però puoi disabilitare i video anche in un forum o più che scegli tu basta andare su skin option nel forum che scegli di applicare quel css... post-29-0-64530100-1353858794_thumb.png

Share this post


Link to post
Share on other sites
Michele Bortolato

Grazie, molto utile come cosa,

alla fine ho risolto chreando una skin nuova copia di quella originale, con la differenza che quest'ultima ha in ipb_styles.css la property display:none.

Chi vuole se la setta e a posto così.

Share this post


Link to post
Share on other sites
Michele Bortolato

Un altra cosa: per fare in modo che venga visto il link al video anzichè il video embeddato pensavo di agire nel manage media tag gestendo il tag youtu.be ed inserendo nel template un elemento embedsrc come segue:


<object width="425" height="355"><param name="movie" value="http://youtube.com/v/$2"></param><param name="wmode" value="transparent"></param><embed src="http://youtube.com/v/$2" type="application/x-shockwave-flash" wmode="transparent" width="425" height="355"></embed><embedSrc>http://youtube.com/v/$2</embedSrc></object>

e settando opportunamente i css.

Ma vedo che una volta editate le modifiche i tag nel forum non subiscono variazioni, non capisco quale operazione nella board devo effettuare per vedere il mio nuovo tab embed con l'elemento nuovo.

Grazie

Share this post


Link to post
Share on other sites
Michele Bortolato

Ok, il problema è che ne il tag embedSrc ne l'anchor vengono visualizzate una volta salvate le modifiche al media tag, non le vedo nemmeno nel sorgente della pagina html, non capisco cosa devo fare per vedere le modifiche nel forum.

Share this post


Link to post
Share on other sites
BomAle

conoscendo i bbcode ti potrei dire di fare un recache del bbcode media e/o youtube... selezionando in alto nella pagina di configurazione del bbcode da acp yes per il recache!

Share this post


Link to post
Share on other sites
Michele Bortolato

Adesso funziona, grazie, ma ora che volevo passare alla 3.4 le modifiche che ho fatto vanno perse?

Share this post


Link to post
Share on other sites
BomAle

mi sa che li sovrascrive! ti consiglio di scrivere su un block note il codice e metterlo in una cartella dove tieni tutte le modifiche fatte, in modo tale che non perdi nulla!

Share this post


Link to post
Share on other sites
Caffpow

scusate, se m'intrometto, c'è modo per far si che nella skin mobile i video incorporati ora non visibili vengano visualizzati come link?

Grazie. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Crea Nuovo...

Important Information

By using this site, you agree to our Terms of Use.