Jump to content
_MIX_

Permalink - trasformare gli URL

Recommended Posts

_MIX_

Intanto complimenti a tutta la community :)

Arriviamo al problema,

vorrei capire se posso trasformare gli URL dei PERMALINK (i link di ogni topic ad esempio) dalla formattazione "standard" con punti di domanda e codici numerici a quella con ad. esempio il titolo del codice o in base ad altri parametri (es. l'url di questo topic adesso è

http://www.invisionita.it/forum/topic/1555-permalink-trasformare-gli-url/

)

Vorre ianche sapere se comporta stravolgimenti totali sul database, perchè ho un forum di molti anni con molti utenti e molte risorse caricate.

IP.Board 3.1.2 appena aggiornato

Grazie

Edited by _MIX_

Share this post


Link to post
Share on other sites
najaru

Ciao MIX, benvenuto.

Devi attivare i FURL.

Vai in acp

1. Tools & Settings >

2. System Settings >

3. System >

4. Search Engine Optimization

Friendly URL Features

e attivare i 2 yes di quella sezione, inserendo l'hataccess come indicato.

C onsidera che in questo modo gli url non saranno poi personalizzabili (come fa il vbseo per vb ad esempio), ma la struttura è veramente ottimale.

Share this post


Link to post
Share on other sites
_MIX_

Grazie delle risposta.

Quindi mi confermi che non faccio "casini" nel database fino ad oggi sviluppato attivando i FURL ?

Edited by _MIX_

Share this post


Link to post
Share on other sites
najaru

direi di no.

gli url vengono solo riscritti.

In ogni caso è sempre assolutamente consigliabile avere un backup ben fatto del database prima di procedere a modifiche del genere

Share this post


Link to post
Share on other sites
_MIX_

direi di no.

gli url vengono solo riscritti.

In ogni caso è sempre assolutamente consigliabile avere un backup ben fatto del database prima di procedere a modifiche del genere

Sicuramente sta scritto da qualche parte sul sito... e mi scuso se non sono riuscito a trovarlo...

Ma il "backup ben fatto" ci sono delle metodologie da preferire al posto di altre ?

Ho un DB MySQL su Aruba, ma visto che la pesantezza del DB è maggiore di 128 MB (a quanto ho capito, mi sembra sia il limite per download/upload del salvataggio "normale" del pannello di PHPmyAdmin/MySQL per una politica di "controllo"... )

Un tecnico mi fà utilizzare il MySQL-Dumper.

Mi piacerebbe avere una conferma :) oppure una dritta per una miglior "mnagement" dei backup.

Grazie ancora.

Share this post


Link to post
Share on other sites
najaru

Smentisco la tua dichiarazione. :)

Ho scaricato stamattina un database da aruba di 600 mega.

Il problema è nell'upload, che limitano a 512mb.

Magari fatti doppio backup , uno normale, e uno con lo zip.......

Share this post


Link to post
Share on other sites
_MIX_

Bene :)

Stasera faccio una prova in prima persona (fino ad oggi utilizzando il dumper impostato dal tecnico non avevo mai provato in prima persona dal pannello, mi attenevo a quello che mi era stato detto)

najaru Hai mai utilizzato My-SQL-Dumper ?

Se funziona quello da pannello di PHP-MyAdmin posso "abbandonare" il Dumper ?

Share this post


Link to post
Share on other sites
_MIX_

Scusa se faccio tante domande, ma sono come un bimbo che ha scoperto un gioco nuovo e vuole capire come funziona :)

Se attivo i FURL tutti i link "vecchi" anche quelli interni ai post che linkano ad altri post dello stesso forum (penso a tutte le risorse, ecc ecc)

vengono "ricostruiti" e quindi sono sempre cunsultabili, oppure mi salta tutto il sistema di link creati prima dell'attivazione dei FURL ?

(Chiedo credo sia importante per non perdere lo storico e le connessioni anche esterne a tutte le nostre risorse)

Share this post


Link to post
Share on other sites
najaru

Se non sbaglio dovrebbe fare in automatico il redirect.

Purtroppo al momento non riesco a provare. Comunque ormai i FURL sono "quasi d'obbligo" se ti interessa un minimo di indicizzazione.....

Registratene uno vecchio. Attiva i furl e vedi se te lo ridireziona

Share this post


Link to post
Share on other sites
_MIX_

Abbiamo seguito tutti i passaggi indicati ma non è successo niente :ph34r:

Abbbiamo ancora i link "non furbi"

Se vuoi vedere il portale è: www.psdrevolution.it

Share this post


Link to post
Share on other sites
najaru

perchè se hai convertito dalla IPB2 nel conf_global ti manca questo, aggiungilo in fondo, prima della chiusura.

$INFO['use_friendly_urls'] = '1';

comunque ti confermo che viene eseguito il redirect dai vecchi url, provato ora.

Share this post


Link to post
Share on other sites
_MIX_

perchè se hai convertito dalla IPB2 nel conf_global ti manca questo, aggiungilo in fondo, prima della chiusura.

$INFO['use_friendly_urls'] = '1';

comunque ti confermo che viene eseguito il redirect dai vecchi url, provato ora.

Con l'aggiunta di quel codice sembra andare tutto ok :ph34r:

W i FURL ! :ph34r:

Torno al lavoro sul portale perchè adesso devo capire perchè mi è rimasto delle scritte con delle lettere accentatè male qua e là tipo questi sotto:

# I 20 utenti più attivi di oggi

# Utenti più attivi in totale

E' possibile che siano delle traduzioni errate dall'ENG al ITA ?

(i pacchetti di traduzione sono quelli di invisionita caricati tramite ftp perchè Aruba dava time out con quello unico)

Ancora grazie pertutto :ph34r:

PS: se devo aprire un topic in ara traduzione dimmelo che magari mischiare più problemi in un solo topic non è il massimo :ph34r:

Share this post


Link to post
Share on other sites
_MIX_

hai risolto il problema dei caratteri?

Eccomi, scusa ma sono stato molto impegnato e non sono potuto andare avanti con la manodopera :D

Allora ci ho guardato adesso:


Tools & Settings  >  
System Settings >
Settings: Server Environment >

[Document Character Set
This is the "charset" for all ACP and public documents. We strongly recommend UTF-8]

Il valore era iso-8859-15
messo UTF-8

Mi sono spariti caratteri dai testi della board (che ti ho scritto nel messaggio sopra) ma adesso, nei post degli utenti i caratteri accentati vengono sostituiti con un punto interrogativo -> �

Ci sono altri parametri da variare ?

Edited by _MIX_

Share this post


Link to post
Share on other sites
haldo

Eccomi, scusa ma sono stato molto impegnato e non sono potuto andare avanti con la manodopera :D

Allora ci ho guardato adesso:


Tools & Settings >
System Settings >
Settings: Server Environment >

[Document Character Set
This is the "charset" for all ACP and public documents. We strongly recommend UTF-8]

Il valore era iso-8859-15
messo UTF-8

Mi sono spariti caratteri dai testi della board (che ti ho scritto nel messaggio sopra) ma adesso, nei post degli utenti i caratteri accentati vengono sostituiti con un punto interrogativo -> �

Ci sono altri parametri da variare ?

ma anche nei nuovi post??

credo che ti siano rimasti solo nei vecchi post, perchè sono stati salvati nel db con la vecchia codifica

vai nel db e guarda dentro al db come sono salvati

ciao

Share this post


Link to post
Share on other sites
_MIX_

ma anche nei nuovi post??

credo che ti siano rimasti solo nei vecchi post, perchè sono stati salvati nel db con la vecchia codifica

vai nel db e guarda dentro al db come sono salvati

ciao

Giusto nei nuovi post è tutto ok....

Adesso devo trovare come "ricodificare" i vecchi post nel DB :D

Share this post


Link to post
Share on other sites
haldo

Giusto nei nuovi post è tutto ok....

Adesso devo trovare come "ricodificare" i vecchi post nel DB :D

cambia le impostazioni del db da interfaccia di mysql

ma credo che il danno oramai sia fatto

Share this post


Link to post
Share on other sites
_MIX_

Con le impostazioni nell'ACP ad "UTF-8" i nuovi post erano OK

Ma tutti i vecchi post erano semi-inutilizzabili, soprattutto i quote e altre formattazioni...

Il database era formattato con "ISO-8859-1", così abbiamo deciso di unificare l'impostazione in ACP con quella del DB.

Tutti post e parti vecchie sono tornate OK, si sono ripresentate le inesattezze nelle scritte dellayout...

Come posso fare ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Crea Nuovo...

Important Information

By using this site, you agree to our Terms of Use.