Jump to content
  • 0

Errore importazione


Ricsca
 Share

Question

Sto provando a contattare vbulletin 4.2.5 ma dopo un po', ho questo errore 

413F9097-A0C4-4BDC-B1E5-75606051E301.thumb.jpeg.a5f2f15f639afae469ab7732d427effc.jpeg

 

Qui sembra ci possa essere una risposta 

 

STACKOVERFLOW.COM

I've written a MySQL script to create a database for hypothetical hospital records and populate it with data. One of the tables, Department, has a column named Description, which is declared as...

 

Ma non ho capito come si fa...

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Miracolo, è ripartito!

Fai sapere tu di questa cosa a quelli di ipb? 😅

Comunque questo mimdava errore:

Cita
SET @@global.sql_mode= 'NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION';

Mentre con questo mi ha trovato la cella che poi ho modificato manualmente

Cita
select * from INFORMATION_SCHEMA.COLUMNS where COLUMN_NAME like '%status_content%' order by TABLE_NAME

 

  • Like 1
Link to comment
Share on other sites

  • 0
  • Admin

Ciao @Ricsca

Che versione di vBulletin stai cercando di convertire? Che versione di IPS Convert stai usando?

Quello è un problema di vBulletin, ti consiglio di effettuare un backup del database di vBulletin per sicurezza, poi entra in phpmyadmin e nel database di vbulletin esegui questa query:

SET @@global.sql_mode= 'NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION';

Se questo non risolve il tuo problema, dovrai cercare in quale tabella è la colonna status_content e andrà convertita in longtext

Link to comment
Share on other sites

  • 0

I caratteri possono mica c'entrano niente?

347C5157-116C-43B0-B37B-5926E86FD61D.thumb.png.dcf15a9ec9b07006468793f4b8ae14c5.png

Quando inserisco i dati sotto c'è Database Character set che di defoult è UTf8 ma in realtà vbulletin non usa il set UTF8...

Quel campo si riferisce al forum migrato o a quello di VB? Anche perché se si riferisce a vbulletin dovrebbe essere di defoult Latin...

Ho 250 tabelle nel database, come faccio a capire dove sta status_content? 😩

Link to comment
Share on other sites

  • 0
  • Admin
16 minuti fa, Ricsca ha scritto:

Ho 250 tabelle nel database, come faccio a capire dove sta status_content? 😩

Sempre da phpmyadmin esegui:

select * from INFORMATION_SCHEMA.COLUMNS where COLUMN_NAME like '%status_content%' order by TABLE_NAME

 

17 minuti fa, Ricsca ha scritto:

Quando inserisco i dati sotto c'è Database Character set che di defoult è UTf8 ma in realtà vbulletin non usa il set UTF8...

No, non centra nulla quello... è un problema a livello di configurazione database... colpa di vBulletin, io lascerei UTF8

Link to comment
Share on other sites

  • 0

Questo è il risultato... non mi sembra ci sia il database di vbulletin...

Comunque ho migrato il forum sia su bbpress che su mybb e non ho mai avuto un problema di database...

datbase.jpg

Link to comment
Share on other sites

  • 0
  • Admin

Controlla qui:

immagine.png

Se hai già text e da problemi cambialo con longtext, e riprova...

Link to comment
Share on other sites

  • 0
  • Admin

core_member_status_updates, è di IP.Board.

Probabilmente vBulletin permetteva di scrivere negli stati degli utenti vere e proprie poesie, mentre IP.Board ha un limite. (limite davvero grande... Non oso immaginare che dati tu abbia)

Link to comment
Share on other sites

  • 0

Ma quindi non homcapito... Devo modificare la tabella di ipb e non di VB? 

Link to comment
Share on other sites

  • 0
  • Admin
3 minuti fa, Ricsca ha scritto:

Ma quindi non homcapito... Devo modificare la tabella di ipb e non di VB? 

Si, devi modificare la colonna status_content della tabella core_member_status_updates

 

6 ore fa, Askancy ha scritto:
SET @@global.sql_mode= 'NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION';

Hai provato questa stringa sopra?

  • Like 1
Link to comment
Share on other sites

  • 0

Niente... avata e immagini utente non mi son ostate caricate ma non mi ha nemmeno dato l'errore...

Come potrei fare per capire il motivo?

Edited by Ricsca
Link to comment
Share on other sites

  • 0
  • Admin

Mi metti mandi in privato uno screenshot della homepage dell’admincp? Vedrai hai i task che devono lavorare in background o hai sbagliato a mettere l’indirizzo durante la conversione

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. to insert a cookie message.