Jump to content
trattore

https

Recommended Posts

trattore

e possibile far in modo che se imposto il https sul config farlo funzionare solo sul sistema tranne sulle pagine? vorrei che sulle page mi visualizzasse invece che il https, ma le apresse in auto su http

Edited by trattore

Share this post


Link to post
Share on other sites
BomAle

dovresti intervenire dal web server, poichè se non sbaglio nei nuovi aggiornamenti hanno forzato che sia interamente https, se digiti http verrai reindirizzato all'https (se utilizzi la variabile base_url con https).

intervenendo dal web server (apache/nginx...) riesci a servire https per aree/location specifiche mentre per esempio nell'app pages non forzi il redirect dalla porta 80 a 443.

https://serverfault.com/questions/270339/nginx-force-ssl-on-one-path-non-ssl-on-others

oppure utilizzando .htaccess in apache

https://serverfault.com/questions/835314/exclude-a-file-on-an-apache-server-from-ssl-when-the-server-is-protected-with-a

https://stackoverflow.com/questions/27143903/exclude-directory-from-being-forced-to-https

se intraprendi questa strada ripristina base_url con http

Share this post


Link to post
Share on other sites
trattore

su sul config metto http e poi sul sito navigo in https rilevo problemi come le reazioni nei post non le inserisce e ricevo errore,

quindi sono costretto a usare https nel file config_global.

solo che poi non riesco a disabilitare il https nelle pagine dell'app page, ho provato anche a inserire un certificato sul server dedicato apace, ma nelle porte mi mette avviso continuo, sono tre giorni che ci sbatto la testa e non ne esco fuori, le sto provando tutte,

l'unica soluzione è quella che mi permetta di disabilitare il certificato nelle page dell app, ma come?

oppure sul config lasciare http e poi navigare in https con un redirect della pagine che scelgo, ma poi come fisso il problema delle reazioni... mannaggia

Share this post


Link to post
Share on other sites
BomAle
Il 11/5/2018 at 15:36, trattore ha scritto:

rilevo problemi come le reazioni nei post non le inserisce e ricevo errore

riesci ad aprire la console web e trovare l'errore, la causa può essere la presenza/mancanza di header CSP o HSTS

add_header Content-Security-Policy upgrade-insecure-requests;

devi parlarne con l'hosting, per aiutarti nella configurazione.

oppure posso rivederla personalmente.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Crea Nuovo...

Important Information

By using this site, you agree to our Terms of Use.