Jump to content
piripicchio

Stile del player video html5

Recommended Posts

piripicchio

ho un problema con la personalizzazione dello stile del player video in html5,

 

vorrei abbandonare il player in flash affinche' sia possibile vedere i filmati su piu' piattaforme compresi iphone e ipad...

 

ho provato con il codice html5 classico

 

<video width="320" height="240" poster="poster.jpg" controls="controls" preload="none">    <source type="video/mp4" src="myvideo.mp4" />    <source type="video/webm" src="myvideo.webm" />    <source type="video/ogg" src="myvideo.ogv" /></video>

 

che riesco a vedere in tutti i browser compreso safari in iphone e ipad

 

pero'  vorrei personalizzare il video ma non ci riesco...

 

Per esempio... vorrei visualizzare il player come indicato qui http://mediaelementjs.com/

 

Se utilizzo le loro info ed istruzioni in una pagina htm costruita per fare un test... e' tutto ok !

 

Se voglio vedere il player in un post di IPB lo stile rimane sempre quello di default dei browser...

 

Credo che il problema sia il css e uno script da richiamare nel HEAD delle pagine, che ho inserito nel global template di IPB...

 

ma non funziona!

 

<script src="jquery.js"></script><script src="mediaelement-and-player.min.js"></script><link rel="stylesheet" href="mediaelementplayer.css" />

 

come si potrebbe fare?

 

 

Share this post


Link to post
Share on other sites
piripicchio

una verifica banale : mi pare che quei .js non siano in path, hai fatto prove e poi li hai tolti ?

 

si si avevo messo gli indirizzi giusti... e provato a collocare i codice in varie posizioni nell'head del forum... ma niente... (li ho tolti dopo varie prove)

 

sembra che i post del forum siano indipendenti dai css e js riportati nell'head... boh!

 

Come detto...

 

ho provato a costruire una pagina html e tutto era ok...

 

ma con il forum no...

 

niente...

 

si vedono solo i player di default html5

 

piu' che altro per Firefox, Chrome, Safari, Safari iPhone-iPad e Opera mi andrebbe anche bene perche' mostrano il controllo del video (il tasto avvio del filmato)

 

pero' in IE si vede solo passando il mouse sopra... e chi vede il post non ha la sensazione che sia un video ma solo un'immagine....

Edited by piripicchio

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Crea Nuovo...

Important Information

By using this site, you agree to our Terms of Use.